Cookies Disclaimer

I agree Our site saves small pieces of text information (cookies) on your device in order to authenticate logins, deliver better content and provide statistical analysis. You can adjust your browser settings to prevent our site from using cookies, but doing so will prevent some aspects of the site from functioning properly.

PFO can Run in LINUX

Azure_Zero
Ryan if you want I could run some more tests,
but would need to know what info your looking for.
Vermilion
I did some testing myself pre early enrollment running the game on linux. I was using Ubuntu Gnome 14.04 at the time with what was the latest version of wine 1.7. The performance of the game under wine was good. I was using a Geforce GTX 560ti then and I didn't notice any significant difference with the smoothness of the engine or the textures. However the fact that the game doesn't patch in wine is major issue.

I consider my self to still be a novice at getting programs to work in wine, and with that limited knowledge it looks like the patcher is getting hung up on the embedded web browser function that shows the patch notes. Wine referenced some outdated or unused packages that could make it worked but I couldn't find much info on getting any of them. I would imagine getting the patcher working would probably require doing what was done with Lotro, which was the player base writing a python script to connect to the patch server and patch the game files.
Azure_Zero
Nice, so that's two versions of Linux that have been tested and passed.
Baron
I think we need to Crowdforge a linux installer
Self-styled Warden of the East, Protector of Baron´s Folly, Hero of the first skirmish.
Azure_Zero
Now that would be awesome, if that happened.

Though for now, I say fix the patcher to run in PlayOnLinux.
As some of the 3PP software they use in game might take a very long time to make Linux compatible.

Hoping Ryan or some other GW dev chimes in here, about what could be done to make the game more linux friendly.
Kadere
Work on linux compatability can't possibly be anything like a priority. There is too much else to be done first imo.
Baron
Kadere
Work on linux compatability can't possibly be anything like a priority. There is too much else to be done first imo.

Well, i agree with this… like SHIELDS… i really want proper shields… smile

But yeah, if i were "promised" a linux native, i would make do with the roundabout way of playing it. I´m changing to a linux dist really soon.
Self-styled Warden of the East, Protector of Baron´s Folly, Hero of the first skirmish.
Kitsune
I have some experience getting games to run on Linux, because frankly, I love Linux much more than I do Windows. Unfortunately there were some games that nobody could ever get to work properly (or with good performance) on Linux, so I did eventually switch back to Win7. The announcement that there was no planned release of PFO on Linux was the final nail in that coffin.

However, I might spin up a VM (or an additional partition) and see if I can get the blasted patcher to work in Ubuntu…
Azure_Zero
I'm hoping that it's only one or two things that make the patcher broken, and that it can be fixed quickly.
Azure_Zero
I'll be putting up a Guide on installing PFO in Linux for those who are insterested in running PFO using Linux.
 
You must be logged into an enrolled account to post