The Can't connect to map-server -10.3 error should be fixed in the EE 4.1 build.

If you've gotten this error contact before today contact the support to to fix the character into normal space.