Cookies Disclaimer

I agree Our site saves small pieces of text information (cookies) on your device in order to authenticate logins, deliver better content and provide statistical analysis. You can adjust your browser settings to prevent our site from using cookies, but doing so will prevent some aspects of the site from functioning properly.

Pathfinder Online will be ending operations on November 28, 2021. For more details please visit our FAQ.

HOW TO: install and run PFO in Linux.

@ Mark Kalmes,
Can you give the console command as an example of running it from Play on Linux, with and without the -eula Accept.
Would be nice if this could get some love, i'm stuck and not being able to play. smile
The best way I can think of at the moment is a separate console only patcher, with a console based menu for; accepting eula, verifying game cache, patching game, and running the game.

I can make that menu in under 10 minutes in C++, though the functions of each item, I could not do in that 10 minutes.
Ryan Dancey
Did Mark's update to let you run the Patcher without the UI not work?
There was not enough information to even get started in trying to run it.
As I tried with what I did know, and could not get the sucker to run.
Tried today on my Ubuntu.

Patcher is installed and I stuck trying to make it working until I found this thread.

Running it with -console parameter somewhat helps. It runs (unlike GUI version that crashes immediately), download eula.cpf and current.cpf and then quit saying "This parameter is only available on Linux/UNIX machines."

Well, I am on Linux machine, but I run patcher through wine, sure it seems like Windows. So now I stuck here.

Complete output after running with -console:
WINEPREFIX=/home/wine/pfo wine /home/wine/pfo/drive_c/Program\ Files\ \(x86\)/Pathfinder\ Online/Patcher.exe -console
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
All supplied parameters: C:\Program Files (x86)\Pathfinder Online\Patcher.exe -console
Downloading file 'C:\users\ek\Temp\pfo_patcher\eula.cpf' from ''
Downloading file 'C:\users\ek\Temp\pfo_patcher\current.cpf' from ''

This parameter is only available on Linux/UNIX machines.
Well, I am on Linux machine, but I run patcher through wine, sure it seems like Windows. So now I stuck here.

You should run the linux Patcher.exe (with -console) through the native Ubuntu console/terminal instead of WINE. Please try that and let us know if you still experience issues.
That works. I have to install mono though: sudo apt-get install mono-complete
Could you make a step by step process of it, so I can add that to the Opening Post for new or beginner Linux users.
Yes, I got PFO to run on Linux Again, and it is somewhat a pain to do, as it'll require a windows machine to get the updates.
You must be logged into an enrolled account to post