Cookies Disclaimer

I agree Our site saves small pieces of text information (cookies) on your device in order to authenticate logins, deliver better content and provide statistical analysis. You can adjust your browser settings to prevent our site from using cookies, but doing so will prevent some aspects of the site from functioning properly.

Something wrong with the Paizo forums?

Nihimon
I can't log in and the forums are blank for me.
Nihimon murmurs in sheer ecstasy as the magic courses through his veins
Azure_Zero
The paizo database might of underwent maintenance.
Rynnik
Nihimon
I can't log in and the forums are blank for me.
You are probably just banned.

smile
Not a member, representative, or supporter of Brighthaven Alliance.
Tink says Stab
Tink was also banned then, RIP.
Tink quivers in sheer euphoria as the dank memes course through his fedora
Smitty
Got this email a week ago or so, doesn't sound like that is your issue, but figured id post it in case it is.
Starting Tuesday, June 23, 2015 paizo.com users with older web browsers will no longer be able to log in to paizo.com, removing access to the secure portions of our website (including "My Account", "My Downloads", and "My Pathfinder Society"smile. This also removes the ability of users with older web browsers to post on the paizo.com forums and check out in the store. Users with recent browsers will not be affected.
What browsers does this affect?

This affects browsers that support only version 1.0 of the TLS security protocol, which is being phased out by many websites that handle secure information. Browsers that support TLS 1.1 and newer are unaffected. The following are the earliest versions of the most common browsers that support TLS 1.1 by default:

Android OS Browser 5.0, Recommended 5.1
Chrome 22, Recommended 43
Firefox 27, Recomended 38
Internet Explorer 11, Recommended 11 and onward (including Microsoft Edge)
Opera 14, Recommended 29
Safari 7 (Requires OSX 10.9 Mavericks), Recommended 8 (Requires OSX 10.10 Yosemite)
Safari (Mobile) iOS 5, Recommended iOS 8—Supported devices include the Apple TV (2nd generation and up), any iPad, iPhone 3GS and up, and iPod Touch (3rd generation and up).

After this change, users whose browsers do not support TLS 1.1 will have issues accessing any page that has https://secure.paizo.com in the URL. We encourage our users to update their browsers for optimal experience, data security, and support on paizo.com. (Users accessing only non-secure pages of paizo.com will also be unaffected, but note that very few users access only non-secure pages; in fact, you are only getting this email because you have an account on paizo.com, which means you have accessed secure pages of paizo.com in the past.)
Nihimon
Well, they must've lifted my ban because I can see the forums again.
Nihimon murmurs in sheer ecstasy as the magic courses through his veins
 
You must be logged into an enrolled account to post